Upgrading to version 1.0 III

I have found the second and last cause of my upgrading problems: there is a small bug in Model->save() which prevented the validation of the model fields. You find a patch on https://trac.cakephp.org/ticket/744. So, with that patch applied, all my tests run without failures. Hooray!

Update (2006-05-06): It transpired that the bug was in the advanced validation approach I use, and not in Model->save().

2 Comments

  1. Posted May 3, 2006 at 8:04 pm | Permalink

    What software uses for testing?

  2. Posted May 4, 2006 at 7:40 am | Permalink

    I use Selenium (http://www.openqa.org/selenium/) and SimpleTest (http://www.lastcraft.com/simple_test.php).


One Trackback/Pingback

  1. […] small bug in the advanced validation approach I already wrote that I had problems with the validation after upgrading to version 1.0 of CakePHP. At that time, I […]

Post a Comment

Required fields are marked *
*
*

%d bloggers like this: